Сервер Win 2012 уходит в ребут изза ZP

dengivseti

Client
Регистрация
18.08.2016
Сообщения
39
Благодарностей
3
Баллы
8
[QUOTE="Lord_Alfred, (такие настройки стоят очень давно и уже были выключения после этого)[/QUOTE]

Решение проблемы так и не нашлось? А то что на ноуте что на серваках падает винда
 

catol

Client
Регистрация
05.07.2012
Сообщения
277
Благодарностей
98
Баллы
28
Нет, это боль до сих пор.

Есть наблюдение что падает чаще если в проекте валятся ошибки(моё наблюдение).
 

Sefroz

Client
Регистрация
20.11.2017
Сообщения
54
Благодарностей
3
Баллы
8
У кого то еще проблемы ушли при установке win2016 ? У меня на серверах симптомы везде теже. Везде 2012
 

Mikhail B.

Moderator
Регистрация
23.12.2014
Сообщения
14 364
Благодарностей
5 423
Баллы
113

Sefroz

Client
Регистрация
20.11.2017
Сообщения
54
Благодарностей
3
Баллы
8
м, а каким тут боком обновления? После них сразу начинаются подобные выпадания?
 

Mikhail B.

Moderator
Регистрация
23.12.2014
Сообщения
14 364
Благодарностей
5 423
Баллы
113
м, а каким тут боком обновления? После них сразу начинаются подобные выпадания?
нет. просто обновления могут перезагрузить систему. По этому я на всякий случай сказал про обновления.
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
Присоединяюсь. Проблема на разных машинах проявляется. Похоже когда запущен ZP и CM одновременно. Но сервак не ребутится, похоже что крашится Explorer. В логах инфа такая:

Имя журнала: Application
Источник: Application Error
Дата: 08.11.2018 8:18:15
Код события: 1000
Категория задачи:(100)
Уровень: Ошибка
Ключевые слова:Классический
Пользователь: Н/Д
Компьютер: ZennoPC
Описание:
Имя сбойного приложения: ZennoLab.AudioMute.exe, версия: 1.0.0.0, отметка времени: 0x5bbc83fd
Имя сбойного модуля: KERNELBASE.dll, версия: 6.1.7601.19018, отметка времени 0x5609fed4
Код исключения: 0xe0434352
Смещение ошибки: 0x0000c42d
Идентификатор сбойного процесса: 0x19c0
Время запуска сбойного приложения: 0x01d4772272e27868
Путь сбойного приложения: C:\Program Files (x86)\ZennoLab\RU\ZennoPoster Standard\5.22.1.0\Progs\ZennoLab.AudioMute.exe
Путь сбойного модуля: C:\Windows\syswow64\KERNELBASE.dll
Код отчета: b13aad92-e315-11e8-880b-52540061b876
Xml события:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2018-11-08T05:18:15.000000000Z" />
<EventRecordID>2164</EventRecordID>
<Channel>Application</Channel>
<Computer>ZennoPC</Computer>
<Security />
</System>
<EventData>
<Data>ZennoLab.AudioMute.exe</Data>
<Data>1.0.0.0</Data>
<Data>5bbc83fd</Data>
<Data>KERNELBASE.dll</Data>
<Data>6.1.7601.19018</Data>
<Data>5609fed4</Data>
<Data>e0434352</Data>
<Data>0000c42d</Data>
<Data>19c0</Data>
<Data>01d4772272e27868</Data>
<Data>C:\Program Files (x86)\ZennoLab\RU\ZennoPoster Standard\5.22.1.0\Progs\ZennoLab.AudioMute.exe</Data>
<Data>C:\Windows\syswow64\KERNELBASE.dll</Data>
<Data>b13aad92-e315-11e8-880b-52540061b876</Data>
</EventData>
</Event>

#####################################################################


Имя журнала: Application
Источник: .NET Runtime
Дата: 08.11.2018 8:18:14
Код события: 1026
Категория задачи:Отсутствует
Уровень: Ошибка
Ключевые слова:Классический
Пользователь: Н/Д
Компьютер: ZennoPC
Описание:
Приложение: ZennoLab.AudioMute.exe
Версия платформы: v4.0.30319
Описание. Процесс был завершен из-за необработанного исключения.
Сведения об исключении: System.Runtime.InteropServices.COMException
Стек:
в System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32, IntPtr)
в System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32)
в NAudio.CoreAudioApi.MMDeviceEnumerator.GetDefaultAudioEndpoint(NAudio.CoreAudioApi.DataFlow, NAudio.CoreAudioApi.Role)
в ZennoLab.AudioMute.Program+NotificationClientImplementation..ctor(NAudio.CoreAudioApi.MMDeviceEnumerator)
в ZennoLab.AudioMute.Program.Main(System.String[])

Xml события:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name=".NET Runtime" />
<EventID Qualifiers="0">1026</EventID>
<Level>2</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2018-11-08T05:18:14.000000000Z" />
<EventRecordID>2163</EventRecordID>
<Channel>Application</Channel>
<Computer>ZennoPC</Computer>
<Security />
</System>
<EventData>
<Data>Приложение: ZennoLab.AudioMute.exe
Версия платформы: v4.0.30319
Описание. Процесс был завершен из-за необработанного исключения.
Сведения об исключении: System.Runtime.InteropServices.COMException
Стек:
в System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32, IntPtr)
в System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32)
в NAudio.CoreAudioApi.MMDeviceEnumerator.GetDefaultAudioEndpoint(NAudio.CoreAudioApi.DataFlow, NAudio.CoreAudioApi.Role)
в ZennoLab.AudioMute.Program+NotificationClientImplementation..ctor(NAudio.CoreAudioApi.MMDeviceEnumerator)
в ZennoLab.AudioMute.Program.Main(System.String[])
</Data>
</EventData>
</Event>
 

Sergodjan

Administrator
Команда форума
Регистрация
05.09.2012
Сообщения
19 280
Благодарностей
8 610
Баллы
113
Присоединяюсь. Проблема на разных машинах проявляется. Похоже когда запущен ZP и CM одновременно. Но сервак не ребутится, похоже что крашится Explorer. В логах инфа такая:

Имя журнала: Application
Источник: Application Error
Дата: 08.11.2018 8:18:15
Код события: 1000
Категория задачи:(100)
Уровень: Ошибка
Ключевые слова:Классический
Пользователь: Н/Д
Компьютер: ZennoPC
Описание:
Имя сбойного приложения: ZennoLab.AudioMute.exe, версия: 1.0.0.0, отметка времени: 0x5bbc83fd
Имя сбойного модуля: KERNELBASE.dll, версия: 6.1.7601.19018, отметка времени 0x5609fed4
Код исключения: 0xe0434352
Смещение ошибки: 0x0000c42d
Идентификатор сбойного процесса: 0x19c0
Время запуска сбойного приложения: 0x01d4772272e27868
Путь сбойного приложения: C:\Program Files (x86)\ZennoLab\RU\ZennoPoster Standard\5.22.1.0\Progs\ZennoLab.AudioMute.exe
Путь сбойного модуля: C:\Windows\syswow64\KERNELBASE.dll
Код отчета: b13aad92-e315-11e8-880b-52540061b876
Xml события:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2018-11-08T05:18:15.000000000Z" />
<EventRecordID>2164</EventRecordID>
<Channel>Application</Channel>
<Computer>ZennoPC</Computer>
<Security />
</System>
<EventData>
<Data>ZennoLab.AudioMute.exe</Data>
<Data>1.0.0.0</Data>
<Data>5bbc83fd</Data>
<Data>KERNELBASE.dll</Data>
<Data>6.1.7601.19018</Data>
<Data>5609fed4</Data>
<Data>e0434352</Data>
<Data>0000c42d</Data>
<Data>19c0</Data>
<Data>01d4772272e27868</Data>
<Data>C:\Program Files (x86)\ZennoLab\RU\ZennoPoster Standard\5.22.1.0\Progs\ZennoLab.AudioMute.exe</Data>
<Data>C:\Windows\syswow64\KERNELBASE.dll</Data>
<Data>b13aad92-e315-11e8-880b-52540061b876</Data>
</EventData>
</Event>

#####################################################################


Имя журнала: Application
Источник: .NET Runtime
Дата: 08.11.2018 8:18:14
Код события: 1026
Категория задачи:Отсутствует
Уровень: Ошибка
Ключевые слова:Классический
Пользователь: Н/Д
Компьютер: ZennoPC
Описание:
Приложение: ZennoLab.AudioMute.exe
Версия платформы: v4.0.30319
Описание. Процесс был завершен из-за необработанного исключения.
Сведения об исключении: System.Runtime.InteropServices.COMException
Стек:
в System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32, IntPtr)
в System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32)
в NAudio.CoreAudioApi.MMDeviceEnumerator.GetDefaultAudioEndpoint(NAudio.CoreAudioApi.DataFlow, NAudio.CoreAudioApi.Role)
в ZennoLab.AudioMute.Program+NotificationClientImplementation..ctor(NAudio.CoreAudioApi.MMDeviceEnumerator)
в ZennoLab.AudioMute.Program.Main(System.String[])

Xml события:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name=".NET Runtime" />
<EventID Qualifiers="0">1026</EventID>
<Level>2</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2018-11-08T05:18:14.000000000Z" />
<EventRecordID>2163</EventRecordID>
<Channel>Application</Channel>
<Computer>ZennoPC</Computer>
<Security />
</System>
<EventData>
<Data>Приложение: ZennoLab.AudioMute.exe
Версия платформы: v4.0.30319
Описание. Процесс был завершен из-за необработанного исключения.
Сведения об исключении: System.Runtime.InteropServices.COMException
Стек:
в System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32, IntPtr)
в System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32)
в NAudio.CoreAudioApi.MMDeviceEnumerator.GetDefaultAudioEndpoint(NAudio.CoreAudioApi.DataFlow, NAudio.CoreAudioApi.Role)
в ZennoLab.AudioMute.Program+NotificationClientImplementation..ctor(NAudio.CoreAudioApi.MMDeviceEnumerator)
в ZennoLab.AudioMute.Program.Main(System.String[])
</Data>
</EventData>
</Event>
Пробуйте в Настройках ЗП снять галку Отключать звук и перезагрузить ЗП.
ZennoLab.AudioMute.exe не будет подниматься.
Вообще на сервере обычно нет аудиоподсистемы или она не используется, следует эту галку первым делом выключать, чтобы не нагружать сервак лишней работой.
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
Пробуйте в Настройках ЗП снять галку Отключать звук и перезагрузить ЗП.
ZennoLab.AudioMute.exe не будет подниматься.
Вообще на сервере обычно нет аудиоподсистемы или она не используется, следует эту галку первым делом выключать, чтобы не нагружать сервак лишней работой.
Галку сниму, но не понятно почему я должен об этом думать. Может быть Зенка сама проверит есть ли подсистема или нет и установит необходимые параметры?
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
Сделал, не помогло. Крашится explorer вместе со всеми процессами.
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
В логах проблемы с аудио нет, но проблема с крашем осталась.
 

Sergodjan

Administrator
Команда форума
Регистрация
05.09.2012
Сообщения
19 280
Благодарностей
8 610
Баллы
113
Сделал, не помогло. Крашится explorer вместе со всеми процессами.
Если даже explorer крашится, то это не совсем стабильная среда для работы Зеннопостера, в том числе.

В логах проблемы с аудио нет, но проблема с крашем осталась.
Как раз у вас были проблемы с поднятием процесса подавления звука на сервере.
Не факт что проблема с ребутами из-за него, но лучше в этом случае перебдеть, как бы.

PS: На форуме есть сигналы по хорошей работе на 2016 server (без ребутов и выходов из уч. записей). Попробуйте в кр. случае сменить операционку на 2016.
 
Последнее редактирование:

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
Если даже explorer крашится, то это не совсем стабильная среда для работы Зеннопостера, в том числе.


Как раз у вас были проблемы с поднятием процесса подавления звука на сервере.
Не факт что проблема с ребутами из-за него, но лучше в этом случае перебдеть, как бы.

PS: На форуме есть сигналы по хорошей работе на 2016 server (без ребутов и выходов из уч. записей). Попробуйте в кр. случае сменить операционку на 2016.

Explorer крашится - это следствие, а не причина. Сервак в цоде на хорошем оборудовании.
Галочку отключил давно уже, ребутил сервер.

2016 жрет драгоценные ресурсы.

Спасибо.
 

Sergodjan

Administrator
Команда форума
Регистрация
05.09.2012
Сообщения
19 280
Благодарностей
8 610
Баллы
113
Сервак в цоде на хорошем оборудовании.
Хорошее оборудование, это когда эксплорер за несколько лет не покрашился ни разу, при активном использовании Зеннопостера, на домашнем ПК к примеру.
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
Хорошее оборудование, это когда эксплорер за несколько лет не покрашился ни разу, при активном использовании Зеннопостера, на домашнем ПК к примеру.
Переставил на домашний ПК: Core i5, 8Гб ОЗУ, 2012 R2.
Проблема точно такая же. Как будем решать?
 

Sergodjan

Administrator
Команда форума
Регистрация
05.09.2012
Сообщения
19 280
Благодарностей
8 610
Баллы
113
Переставил на домашний ПК: Core i5, 8Гб ОЗУ, 2012 R2.
Проблема точно такая же. Как будем решать?
Попробуйте полностью обновить систему, после этого, после нового воспроизведения проблемы, сделайте диагностику (пришлите репорт).
В качеcтве загрузочного образа что используете, пират-сборку или родной оригинальный образ?
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
Попробуйте полностью обновить систему, после этого, после нового воспроизведения проблемы, сделайте диагностику (пришлите репорт).
В качеcтве загрузочного образа что используете, пират-сборку или родной оригинальный образ?
Система обновлена полностью. репорт пришлю при следующем краше.
Системы на которых проблема одинаково проявлялась в теч последних двух недель:
1) Windows 7 - пиратка
2) Windows 2008R2 - Лицуха
3) Windows 2012R2 - VL
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
Образы оригинальные с VLSC, сборок нет. Я их никогда не использую.
 

Mikhail B.

Moderator
Регистрация
23.12.2014
Сообщения
14 364
Благодарностей
5 423
Баллы
113
@Zmitrok62 А у вас с железом все нормально? Скачайте программу AIDA64 и запустите стресс тест (на всякий случай следите за температурами).
Только надо ставить Extreme или Business Edition.

P.S. При установке снимите галку "Сделать стартовой.."
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
@Zmitrok62 А у вас с железом все нормально? Скачайте программу AIDA64 и запустите стресс тест (на всякий случай следите за температурами).
Только надо ставить Extreme или Business Edition.

P.S. При установке снимите галку "Сделать стартовой.."
Да все норм. До этого Зенка была в ЦОДе, там холодно. AIDA64 говорит что выше 55 градусов не поднимается темп ядер на моем системнике дома.
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
Попробуйте полностью
обновить систему, после этого, после нового воспроизведения проблемы,
сделайте диагностику (пришлите репорт).
В качеcтве загрузочного образа что используете, пират-сборку или
родной оригинальный образ?
Добрый день. Вчера поставил в ночь стресс-тест проца. Утром он еще
работал, температура ядер макс 55 градусов.
Сегодня в ночь запустил Зенку. В час ночи она сложилась. В системных
журналах ничего нет на удивление =(

Хочу заметить, что сервер не ребутится, такое ощущение, что происходит
выход из учетки. Т.е. когда я захожу на сервак после краша, то
инициализируется мой пользователь (панель упр сервером запускатся,
программы из авторана и т.д.)

А еще хочу заметить, что тоже самое происходило на сервере в ЦОД с
Win7, когда еще была версия Lite. Абсолютно тоже самое происходило, но
где-то раз в неделю.

Давайте уже как-то решать проблему, я деньги теряю....

Report: https://yadi.sk/d/WLJK-KiIFIeMeg

Спасибо.
 

Sergodjan

Administrator
Команда форума
Регистрация
05.09.2012
Сообщения
19 280
Благодарностей
8 610
Баллы
113
Давайте уже как-то решать проблему, я деньги теряю.
Программисты работают над проблемой, ваш репорт приобщу к разборам.
Но в данный момент советую вам перейти на 2016 server, чтобы не терять деньги.
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
Программисты работают над проблемой, ваш репорт приобщу к разборам.
Но в данный момент советую вам перейти на 2016 server, чтобы не терять деньги.
Хорошо, спасибо. Проблему локализовать я так понимаю получилось.
 

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
Программисты работают над проблемой, ваш репорт приобщу к разборам.
Но в данный момент советую вам перейти на 2016 server, чтобы не терять деньги.
Подтверждаю, на 2016 проблема не воспроизводится.
 

Mikhail B.

Moderator
Регистрация
23.12.2014
Сообщения
14 364
Благодарностей
5 423
Баллы
113

Zmitrok62

Пользователь
Регистрация
26.06.2018
Сообщения
47
Благодарностей
8
Баллы
8
  • Спасибо
Реакции: che100

Antitesla

Client
Регистрация
16.06.2018
Сообщения
5
Благодарностей
0
Баллы
1
Коллеги, также подтверждаю наличие этой проблемы на различном оборудовании под управлением 2012R2. Кто-то нашел решение кроме обновления до Windows 2016?
 

Кто просматривает тему: (Всего: 1, Пользователи: 0, Гости: 1)