[SOLVED] Project Working Fine In PM but not ZP4

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
Hi guys,

im new to zenno and thought i was picking the basics up quite fast. Very impressed so far.

I spent hours learning, following the tutorials, and have made a WP template that registers, confirms, and posts to WP.

Works AMAZINGLY in PM, but when i load it into ZP4 my troubles start.

Sometimes it will say it has completed successfully but in reality it has taken about 5 mins to do nothing.
Sometimes it will say "active tab of instance not found". with some long string of digits.

Slightly confused as to why it works perfectly in PM but not Zenno.

Can anyone help with this at all please?
Thanks
 

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
also i have checked and have both base.exe and base_.exe in the progs folder
 

rostonix

Administrator
Команда форума
Регистрация
23.12.2011
Сообщения
29 084
Благодарностей
5 610
Баллы
113
Analyze which step falls.
If there's some action on page, try to insert small pause before this action.
 
  • Спасибо
Реакции: loveforfire33

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
thanks for the reply,

i have tried to find a way to do that but i cannot find a log or a browser to see what is happening? i simply get "success" or the error i noted above in the lo
 

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
also the error i get sometimes is
Source "Run Web Browser Tab action id (somelong number)"
"active tab of instance not found". Instance (some long number)
 

rostonix

Administrator
Команда форума
Регистрация
23.12.2011
Сообщения
29 084
Благодарностей
5 610
Баллы
113
Right click in log on failed action and choose copy Id
In project maker use search at the top and paste copied data
 
  • Спасибо
Реакции: loveforfire33

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
just reinstalled with the same errors
 

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
ok thanks ill try that now
 

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
Ok, slightly more confused now!

the error is going to the second thing in my project.

First thing is clear cookies. seems to be ok

Second thing is simply a go to page "http://wordpress.com" and thats what fails?
 

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
aha we might be getting somewhere.

when i run it in MP i now see "failed to open file" on step1.

but on step 1 i am only trying to clear cookies.
 

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
i changed the path from {-Project.Directory-} to the actual file path and im not getting the error anymore.

However it is saying the project is completed successfully when it isnt doing anything.
 

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
i think i might have an idea what the problem is. but i have no idea how to fix it.

i should have mentioned that i am running PM on a separate machine to ZP.

when i try to run debug in PM on the machine that ZP is installed on, PM crashes (specifically as soon as the browser opens). This is simliar to the error that ZP was mentioning. Does this help diagnose the issue at all?

Also thank you very much for your help so far :-)
 

rostonix

Administrator
Команда форума
Регистрация
23.12.2011
Сообщения
29 084
Благодарностей
5 610
Баллы
113
I think it have to be vista with sp2 installed.

+ make sure you have microsoft visual c++ 2010
+ .NET frameworks 3.5 and 4

Also check if file base.exe exist in zennoposter folder (there have to be two files: base.exe and base_.exe)
If its not there, reinstall.
 

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
ok i dont have sp2 so ill do that now.

Thanks again
 

rostonix

Administrator
Команда форума
Регистрация
23.12.2011
Сообщения
29 084
Благодарностей
5 610
Баллы
113
I cannot garantee if it helps, i know more about functions rather than hardware :-)
Try at least ;-)
 

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
Urggh i thought that was going to work...

now i have vista SP2
+ make sure you have microsoft visual c++ 2010
+ .NET frameworks 3.5 and 4
and both base.exe's

any other help, i really want to use zennoposter now!
 

loveforfire33

Client
Регистрация
17.07.2012
Сообщения
78
Благодарностей
5
Баллы
0
and now PM wont even open. im getting a new error saying "debugger is found on this machine"

do you guys offer team viewer support or anything? as ZP is unusable at the moment.
 

rostonix

Administrator
Команда форума
Регистрация
23.12.2011
Сообщения
29 084
Благодарностей
5 610
Баллы
113
Well it's 6 am in Russia ) You better wait for future response here :-)
 

sanind

Client
Регистрация
19.11.2011
Сообщения
48
Благодарностей
18
Баллы
8

lokiys

Moderator
Регистрация
01.02.2012
Сообщения
4 137
Благодарностей
976
Баллы
113
I faced with one problem yestrday i finished my current template and what i get. It working in project maker fine but when i add it in ZP nop it opens my webpage then frezze and then after 5 min reload my webpage. And thats all. In log is nothing. I will test a coulpe times and if that do not work i will send my template to support. I Hope you will check that problem.

P.S
This is not my first template in ZP MP
 

Hungry Bulldozer

Moderator
Регистрация
12.01.2011
Сообщения
3 445
Благодарностей
826
Баллы
113
I faced with one problem yestrday i finished my current template and what i get. It working in project maker fine but when i add it in ZP nop it opens my webpage then frezze and then after 5 min reload my webpage. And thats all. In log is nothing. I will test a coulpe times and if that do not work i will send my template to support. I Hope you will check that problem.

P.S
This is not my first template in ZP MP
It might be related with useraagent, try to set custom one
 

Hungry Bulldozer

Moderator
Регистрация
12.01.2011
Сообщения
3 445
Благодарностей
826
Баллы
113
  • Спасибо
Реакции: loveforfire33

lokiys

Moderator
Регистрация
01.02.2012
Сообщения
4 137
Благодарностей
976
Баллы
113

Кто просматривает тему: (Всего: 1, Пользователи: 0, Гости: 1)