Ошибки в многопотоках

Volnov11

Client
Регистрация
15.02.2019
Сообщения
20
Благодарностей
1
Баллы
3
Подскажите в чем может быть проблема. Запускаю шаблон на 30 потоков, работает нормально без ошибок а если ставлю 40 и более, периодично выскакивают ошибки ( Выполнение действия HtmlElement Не найден HTML элемент, по условиям поиска)
 

molotok

Client
Регистрация
17.04.2015
Сообщения
733
Благодарностей
358
Баллы
63
Подскажите в чем может быть проблема. Запускаю шаблон на 30 потоков, работает нормально без ошибок а если ставлю 40 и более, периодично выскакивают ошибки ( Выполнение действия HtmlElement Не найден HTML элемент, по условиям поиска)
Скорее всего не успеваю прогружаться страницы сайта
 

Sergodjan

Administrator
Команда форума
Регистрация
05.09.2012
Сообщения
19 255
Благодарностей
8 605
Баллы
113
Подскажите в чем может быть проблема. Запускаю шаблон на 30 потоков, работает нормально без ошибок а если ставлю 40 и более, периодично выскакивают ошибки ( Выполнение действия HtmlElement Не найден HTML элемент, по условиям поиска)
30-40 потоков может быть серьезной нагрузкой для среднего компьютера и/или не оч. быстрого канала интернет.
Собственно из-за этого могут появляться такие ошибки, элементы сайта начинают прогружаться с задержкой.
Что у вас за машина?
 

Volnov11

Client
Регистрация
15.02.2019
Сообщения
20
Благодарностей
1
Баллы
3
Core i7-4790K, 16 GB RAM , SSD. В диспетчере задач смотрел, проц. загружен до 80% и памяти хватает. В настройках ZP стоит максимальный таймаут инициализации объектов
 

Mikhail B.

Moderator
Регистрация
23.12.2014
Сообщения
14 362
Благодарностей
5 423
Баллы
113

Yuriy Zymlex

Moderator
Команда форума
Регистрация
24.10.2016
Сообщения
6 323
Благодарностей
3 267
Баллы
113

Кто просматривает тему: (Всего: 1, Пользователи: 0, Гости: 1)