Метод .HttpGet() и пустой ответ API Вконтакте

likurg

Client
Регистрация
30.08.2015
Сообщения
75
Благодарностей
5
Баллы
8
Здравствуйте! Подскажите пожалуйста в чем может быть проблема? Я делаю GET запрос к API Вконтакте через метод ZennoPoster.HttpGet(), но ответа от сервиса не приходит в переменную. Если такой запрос ввести в браузере, то ответ от API отображается в браузере, и в браузере Project Maker тоже отображаются полученные данные.
Заранее благодарю за ответы!
 

ibred

Client
Регистрация
04.04.2015
Сообщения
3 835
Благодарностей
3 535
Баллы
113
Вероятно, что проблема не в запросе, а некорректно составленом коде.
Покажите, как отправляете запрос.
 

likurg

Client
Регистрация
30.08.2015
Сообщения
75
Благодарностей
5
Баллы
8
Покажите, как отправляете запрос.
PHP:
string PageId = "217476507";
string CountPosts = "10";
string Filter = "all";
string Tokens = "ТУТ ТОКЕН";
string QeryForApi = String.Format("https://api.vk.com/method/wall.get?owner_id={0}&count={1}&filter={2}&access_token={3}&v=5.92", PageId, CountPosts, Filter, Tokens);
string AnswerFromApi = ZennoPoster.HttpGet(QeryForApi, "", "UTF-8", ZennoLab.InterfacesLibrary.Enums.Http.ResponceType.BodyOnly);
return AnswerFromApi;
 

ibred

Client
Регистрация
04.04.2015
Сообщения
3 835
Благодарностей
3 535
Баллы
113
@likurg запрос корректный, ответ приходит, тестировал на 5.27.1.0.
Какая у Вас версия ZP?

 
  • Спасибо
Реакции: likurg

likurg

Client
Регистрация
30.08.2015
Сообщения
75
Благодарностей
5
Баллы
8
Попробуйте использовать обычный экшен GET
Спасибо разобрался! Проблема была в том что я в запросе не указал прокси, я почему-то думал что по умолчанию будет взят текущий прокси проекта.
 

Ikigai

Client
Регистрация
13.12.2016
Сообщения
275
Благодарностей
27
Баллы
28
Pro версией 5.11.3.0 Не хочет работать кубик Get запрос . Шаблон прикладываю
У меня есть вторая Зенка , 5.27 лайт версия там гет запрос обрабатывает без проблем.
 

Вложения

ibred

Client
Регистрация
04.04.2015
Сообщения
3 835
Благодарностей
3 535
Баллы
113
Pro версией 5.11.3.0 Не хочет работать кубик Get запрос . Шаблон прикладываю
У меня есть вторая Зенка , 5.27 лайт версия там гет запрос обрабатывает без проблем.
Сайт не загружается в версии 5.11.3.0 из-за старого useragent, который генерируется при старте проекта.
Чтобы проект работал на любой версии ZP, укажите useragent явно в HTTP кубике.

Например, такой:
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
 

Ikigai

Client
Регистрация
13.12.2016
Сообщения
275
Благодарностей
27
Баллы
28
Спасибо вам огромное ) Вы лучшие !
Самая большая ценность зеннопостера это в его форуме и фидбеках =)

А я прописывал USer Agenta через другой екшен.
upload_2019-2-27_0-12-28.png
 
Последнее редактирование:

Кто просматривает тему: (Всего: 1, Пользователи: 0, Гости: 1)