Cannot open Spotify Web Player. Help!

Discussion in 'Questions' started by Aronax, Oct 27, 2017.

  1. VladZen

    VladZen Administrator Staff Member

    Joined:
    Nov 5, 2014
    Messages:
    14,466
    Likes Received:
    3,538
    What browser engine is selected in your zennoposter project? You sure it's Chrome?
    Chrome_engine.png

    Also, make sure that flash is properly enabled in it - https://zennolab.com/wiki/en:chrome-enable-flashhttps://zennolab.com/wiki/en:chrome-enable-flash
     
  2. shThs

    shThs Пользователь

    Joined:
    Oct 3, 2018
    Messages:
    49
    Likes Received:
    0
    Yes, here is a screenshot. I am able to load the page, but after logging in, it returns the same error. spotifyerror.jpg
     
  3. shThs

    shThs Пользователь

    Joined:
    Oct 3, 2018
    Messages:
    49
    Likes Received:
    0
  4. shThs

    shThs Пользователь

    Joined:
    Oct 3, 2018
    Messages:
    49
    Likes Received:
    0
    I am still having no luck with this. The Enable player in your browser error message continues to show up. This does not happen when I play it through Chrome outside of ZP. It even works on FireFox and Edge on the same computer. I have followed all the recommendations, but there is something that I must be missing.

    Would appreciate additional help on this, especially from anyone who is able to get this to work properly in ZennoMaker.
     
  5. VladZen

    VladZen Administrator Staff Member

    Joined:
    Nov 5, 2014
    Messages:
    14,466
    Likes Received:
    3,538
    Try using attached dll file. It could be that you have 32-bit Chrome in your system, but copied dll from it to x64 chrome engine in zennoposter.
     

    Attached Files:

    Zymlex likes this.
  6. shThs

    shThs Пользователь

    Joined:
    Oct 3, 2018
    Messages:
    49
    Likes Received:
    0
    Thank you, will try it. I also assume I have created the correct Subdirectory names and placed it in the correct ZP folder as shown in the screenshot from my earlier post.
     
  7. shThs

    shThs Пользователь

    Joined:
    Oct 3, 2018
    Messages:
    49
    Likes Received:
    0
    I am still getting the same failure outcome. I have attached a screenshot to show the directory path of the dll file that you attached in your response.

    Also, this should have nothing to do with the version of ZP I am running correct? I have version 5.29.3.0, but my license recently ran out for me to update to version 5.30. Don't have the money to make the upgrade right now.

    cefpluginserror1.jpg
     
  8. VladZen

    VladZen Administrator Staff Member

    Joined:
    Nov 5, 2014
    Messages:
    14,466
    Likes Received:
    3,538
    Did you restart ProjectMaker after copying dll?
     
  9. shThs

    shThs Пользователь

    Joined:
    Oct 3, 2018
    Messages:
    49
    Likes Received:
    0
    Yes I did. I closed it out and restarted it. I just went ahead and scraped up some money to buy the update. I am installing version 5.30.0 now and will run through the recommended steps again to see if I have better luck. I will also recreate a test project from scratch with a simple visit, no proxy, and see how the browser behaves.
     
  10. shThs

    shThs Пользователь

    Joined:
    Oct 3, 2018
    Messages:
    49
    Likes Received:
    0
    zperror1.jpg I've updated to version 5.30.0.0, copied the Cef folder in the directory, change browser settings to Chrome, added the arguments to it, then started ZM. I still get the enable player message. This is frustrating as I am sure it must be something very minor.

    zperror1.jpg
     
  11. VladZen

    VladZen Administrator Staff Member

    Joined:
    Nov 5, 2014
    Messages:
    14,466
    Likes Received:
    3,538
    You are doing it wrong. Why 2 folders CefPlugins?
    zperror1.png
     
  12. shThs

    shThs Пользователь

    Joined:
    Oct 3, 2018
    Messages:
    49
    Likes Received:
    0
    I did fix that double folder immediately after my last post. That did not make a difference. I closed ZM, re-opened it, and still get the enable player message.
     
  13. VladZen

    VladZen Administrator Staff Member

    Joined:
    Nov 5, 2014
    Messages:
    14,466
    Likes Received:
    3,538
    Try running Chrome without arguments and also set default profile in browser profile settings.
     
  14. shThs

    shThs Пользователь

    Joined:
    Oct 3, 2018
    Messages:
    49
    Likes Received:
    0
    No Luck, I have included a video clip link that will show the following:

    1. A clip of the Spotify web player playing on a standalone chrome browser without problems. Google Chrome Version 75.0.3770.100 (Official Build) (64-bit)
    2. A clip of the directory folder path that shows where the .dll file is located.
    3. A clip of ZM settings without arguments string or browser profile customization.
    4. A clip of ZM making a visit to the exact same URL from step #1, but failing to open the web player.
    5. A clip of ZM settings with arguments string and browser profile customization.
    6. A clip of ZM making a visit to the exact same URL from step #1, but failing to open the web player.
    Click this link to view the video clip in your web browser: https://recordit.co/1iBx2B9VAf The player controls are on the bottom of the page.

    In all of the scenarios above, the web player only plays per item #1 above. All attempts to get it to play with ZM returns the same "Enable player in your browser" error message. Hopefully, the video clip will give you a better understanding of the exact steps I followed and a clear verification of the outcome.
     
    Last edited: Jul 12, 2019 at 5:27 PM

Пользователи просматривающие тему (Пользователей: 0, Гостей: 0)